package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.*?) ([0-9]|0[0-9]|1[0-9]|2[0-3]):([0-5][0-9]):?([0-5][0-9])?( AM| PM)?( [+-]\d{4})?`)
var str = `June 27, 1993 5:10 PM
2013-07-26 09:50:17 -0400`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}