re = /(.*?) ([0-9]|0[0-9]|1[0-9]|2[0-3]):([0-5][0-9]):?([0-5][0-9])?( AM| PM)?( [+-]\d{4})?/
str = 'June 27, 1993 5:10 PM
2013-07-26 09:50:17 -0400'
# Print the match result
str.match(re) do |match|
puts match.to_s
end