package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([01]?\d{1,2}|2[0-4]\d|25[0-5])\.([01]?\d{1,2}|2[0-4]\d|25[0-5])\.([01]?\d{1,2}|2[0-4]\d|25[0-5])\.([01]?\d{1,2}|2[0-4]\d|25[0-5])$`)
var str = `Valid:
000.01.249.255
1.199.200.0
0.0.0.0
Invalid:
1000..256.300
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}