re = /^([01]?\d{1,2}|2[0-4]\d|25[0-5])\.([01]?\d{1,2}|2[0-4]\d|25[0-5])\.([01]?\d{1,2}|2[0-4]\d|25[0-5])\.([01]?\d{1,2}|2[0-4]\d|25[0-5])$/m
str = 'Valid:
000.01.249.255
1.199.200.0
0.0.0.0
Invalid:
1000..256.300
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end