#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=(?:^\w))([A-Za-z ]+)(?<=[^ ])$"
Local $sString = "nsdflj jdf" & @CRLF & _
" ldjsfl" & @CRLF & _
"ljdsf " & @CRLF & _
" ldjflj" & @CRLF & _
"dsfjk " & @CRLF & _
"ljsdfljsdf sdljsdf" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")