$re = '/(?=(?:^\w))([A-Za-z ]+)(?<=[^ ])$/m';
$str = 'nsdflj jdf
ldjsfl
ljdsf
ldjflj
dsfjk
ljsdfljsdf sdljsdf
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);