using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d{4})-(\d{2})-(\d{2})(?:\s+(\d{2}):(\d{2}))?$";
string input = @"2013-05-29 15:15:12";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}