re = /^(\d{4})-(\d{2})-(\d{2})(?:\s+(\d{2}):(\d{2}))?$/
str = '2013-05-29 15:15:12'
# Print the match result
str.match(re) do |match|
puts match.to_s
end