package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\s|^|\(|\[)([A-Z]{1,10}-[1-9][0-9]*)(?:\s|$|\)|\]|:|\.(\s|$))`)
var str = `Reference issue: ABC-123 .
Should not be with hash #ABC-123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}