import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\s|^|\\(|\\[)([A-Z]{1,10}-[1-9][0-9]*)(?:\\s|$|\\)|\\]|:|\\.(\\s|$))";
final String string = "Reference issue: ABC-123 .\n"
+ "Should not be with hash #ABC-123";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}