using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=summary\\"":\\"").*?(?=\\"")";
string input = @"\""alert_id\"":\""123456\"",\""severity\"":\""medium\"",\""summary\"":\""System generated a Medium severity alert\\\\prod_rx.\"",\""title\"":\""123456-test_alert\"",";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}