$re = '/(?<=summary\\\\":\\\\").*?(?=\\\\")/m';
$str = '\\"alert_id\\":\\"123456\\",\\"severity\\":\\"medium\\",\\"summary\\":\\"System generated a Medium severity alert\\\\\\\\prod_rx.\\",\\"title\\":\\"123456-test_alert\\",';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);