using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"height:+.+px?";
string input = @"<img src=""t.jpg"" style=""width:1000px; height: 300px"">";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}