$re = '/height:+.+px?/';
$str = '<img src="t.jpg" style="width:1000px; height: 300px">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);