import re
regex = re.compile(r"(?:\b[\s]?|[^x])([\d]{1}[\d]{2})(?:[^pi]|[\s]?\b)")
test_str = ("This is (321) an example.\n"
"(321) also\n"
"including (321) //basically not possible, but can't hurt.\n"
"this (321) has another group with a p: 122p\n"
"this (321) has another group with a I: 123i\n"
"this x235 should be ignored cause (123) is what i want to match.\n"
"(123) is what i want, not x111 or 125p or 999i\n"
"in this 111 case there is no solution 555\n"
"101 202.something\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")