re = /(?:\b[\s]?|[^x])([\d]{1}[\d]{2})(?:[^pi]|[\s]?\b)/
str = 'This is (321) an example.
(321) also
including (321) //basically not possible, but can\'t hurt.
this (321) has another group with a p: 122p
this (321) has another group with a I: 123i
this x235 should be ignored cause (123) is what i want to match.
(123) is what i want, not x111 or 125p or 999i
in this 111 case there is no solution 555
101 202.something
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end