#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?s)\AKey1:\n(?P<Key1>.*)Key2:\n(?P<Key2>.*?)(?:OptionalKey3:\n(?P<OptionalKey3>.*))?\z"
Local $sString = "Key1:" & @CRLF & _
" SomeValue1" & @CRLF & _
" MoreValue1" & @CRLF & _
"Key2:" & @CRLF & _
" SomeValue2" & @CRLF & _
" MoreValue2" & @CRLF & _
"OptionalKey3:" & @CRLF & _
" SomeValue3" & @CRLF & _
" MoreValue3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")