import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)\\AKey1:\\n(?P<Key1>.*)Key2:\\n(?P<Key2>.*?)(?:OptionalKey3:\\n(?P<OptionalKey3>.*))?\\z";
final String string = "Key1:\n"
+ " SomeValue1\n"
+ " MoreValue1\n"
+ "Key2:\n"
+ " SomeValue2\n"
+ " MoreValue2\n"
+ "OptionalKey3:\n"
+ " SomeValue3\n"
+ " MoreValue3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}