package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\w+\@\w+\.(com|ru|net)`)
var str = `mail@mail.com`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}