use strict;
my $str = '9.25
4.05
1.45
2.35
4.35
2.35
2.85
2.60
2.90
1.32
4.60
18.0
3.15
2.30
3.10
3.75
1.95
3.65
2.45
2.65
3.80
2.00
4.65
2.70
2.45
2.65
3.80
1.75
3.75
4.65
2.55
7.00
1.80
3.55
3.15
2.10
';
my $regex = qr/^(\d+(?:\.\d+)?)\n(\d+(?:\.\d+)?)\n(\d+(?:\.\d+)?)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}