# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\d+(?:\.\d+)?)\n(\d+(?:\.\d+)?)\n(\d+(?:\.\d+)?)"
test_str = ("9.25\n"
"4.05\n"
"1.45\n"
"2.35\n"
"4.35\n"
"2.35\n"
"2.85\n"
"2.60\n"
"2.90\n\n\n"
"1.32\n"
"4.60\n"
"18.0\n"
"3.15\n"
"2.30\n"
"3.10\n"
"3.75\n"
"1.95\n"
"3.65\n\n\n"
"2.45\n"
"2.65\n"
"3.80\n"
"2.00\n"
"4.65\n"
"2.70\n"
"2.45\n"
"2.65\n"
"3.80\n\n\n"
"1.75\n"
"3.75\n"
"4.65\n"
"2.55\n"
"7.00\n"
"1.80\n"
"3.55\n"
"3.15\n"
"2.10\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.