using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)^.*?\K[0-9A-Z]_[0-9A-Z]";
string input = @"248_HIGH_FAN_BLADE,
67B_COOLER_BLADE,
BLADE_LOW_DIM";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}