$re = '/(?m)^.*?\K[0-9A-Z]_[0-9A-Z]/m';
$str = '248_HIGH_FAN_BLADE,
67B_COOLER_BLADE,
BLADE_LOW_DIM';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);