$re = '/^http:\/\/www\.example\.com\/foo\/.*$/';
$str = 'http://www.example.com/foo/bar/index.php?id=1
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);