re = /^http:\/\/www\.example\.com\/foo\/.*$/
str = 'http://www.example.com/foo/bar/index.php?id=1
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end