package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`beg(.*?)end`)
var str = `beg foo end beg bar end beg baz (bat) end beg qux end`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}