$re = '/beg(.*?)end/';
$str = 'beg foo end beg bar end beg baz (bat) end beg qux end';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);