const regex = /(?<=\(|,)\s*(.*?)\s*(?=\)|,)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\(|,)\\s*(.*?)\\s*(?=\\)|,)', 'gm')
const str = `List(UT_LVL_17_CD, UT_LVL_20_CD, 2018 1Q, 2018 2Q, 2018 3Q, 2018 4Q, 2018 FY )`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}