re = /(?<=\(|,)\s*(.*?)\s*(?=\)|,)/m
str = 'List(UT_LVL_17_CD, UT_LVL_20_CD, 2018 1Q, 2018 2Q, 2018 3Q, 2018 4Q, 2018 FY )'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end