#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[^\d]((\+49|0049|0)1[567]\d{1,2}([ \-/]*\d){7})(?!\d)"
Local $sString = "################################### This is allowed ##########################" & @CRLF & _
"+49 15207930698" & @CRLF & _
"+49 15207955279" & @CRLF & _
"+49 915175461907" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"+4915207829969" & @CRLF & _
"+4915368831169" & @CRLF & _
"+491771399487" & @CRLF & _
"+4917697300278" & @CRLF & _
"+4915902955865" & @CRLF & _
"+491771789427" & @CRLF & _
"+4917697400179" & @CRLF & _
"+4915903904567" & @CRLF & _
"+4915902944599" & @CRLF & _
"+491739341284" & @CRLF & _
"+4915902944599" & @CRLF & _
"+4915903904567" & @CRLF & _
"The number +491739341284 with some text" & @CRLF & _
"" & @CRLF & _
"Germany +4915255687865Total SMS: 6758" & @CRLF & _
"This number 015731294508 we need!" & @CRLF & _
"015731294508" & @CRLF & _
"015735995842" & @CRLF & _
"" & @CRLF & _
"015168433343" & @CRLF & _
"Here:015731294508Hallo" & @CRLF & _
"Here:015731294508" & @CRLF & _
"<td>01573 / 1294-508</tr>" & @CRLF & _
"<td>015731294508</tr>" & @CRLF & _
"Eine Nummer: 01515 84 333 78" & @CRLF & _
"Wichtige Nummer:015731294508." & @CRLF & _
"Noch eine Nummer-015731294508," & @CRLF & _
"015731294508Hier" & @CRLF & _
"" & @CRLF & _
"<td>01573 1294 508</tr>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"################################### This is NOT allowed ##########################" & @CRLF & _
"012345678901234" & @CRLF & _
"123w345345345345" & @CRLF & _
"0123456789101191919" & @CRLF & _
"+4915902" & @CRLF & _
"+491590123" & @CRLF & _
"+4915903567" & @CRLF & _
"+49177178796" & @CRLF & _
"+49159039012341" & @CRLF & _
"+491590345985412" & @CRLF & _
"" & @CRLF & _
"Invalid number +491590345985412 within text" & @CRLF & _
"" & @CRLF & _
"+12127319863" & @CRLF & _
"+13322014056" & @CRLF & _
"+12126712234" & @CRLF & _
"+427532697710" & @CRLF & _
"+417868150810" & @CRLF & _
"+287533002875" & @CRLF & _
"" & @CRLF & _
"+49 1739341284" & @CRLF & _
"(+49) 1739341284" & @CRLF & _
"+49 17 39 34 12 84" & @CRLF & _
"+49 (1739) 34 12 84" & @CRLF & _
"+(49) (1739) 34 12 84" & @CRLF & _
"+49 (1739) 34-12-84" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")