# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:\d{10}|(?=[\d-]{11}$)\d{2,4}-\d{6,8})$"
test_str = ("0123456789\n"
"01-23456789\n"
"012-3456789\n"
"0123-456789\n"
"01234567890\n"
"0123-45678901\n"
"0123-4567898\n"
"01234-56789\n"
"012345678-9\n"
"012-3-456789\n"
"-0123456789\n"
"0123456789-\n"
"01-234567")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.