re = /^(?:\d{10}|(?=[\d-]{11}$)\d{2,4}-\d{6,8})$/m
str = '0123456789
01-23456789
012-3456789
0123-456789
01234567890
0123-45678901
0123-4567898
01234-56789
012345678-9
012-3-456789
-0123456789
0123456789-
01-234567'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end