import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "TEST\\s*\\K\\S+";
final String string = "TEST 3098\n"
+ "TEST 3098\n"
+ "TEST 3098\n"
+ "TEST3098\n"
+ "TEST 3098\n"
+ "TEST 3098";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}