$re = '/TEST\s*\K\S+/m';
$str = 'TEST 3098
TEST 3098
TEST 3098
TEST3098
TEST 3098
TEST 3098';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);