package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d+\s*k)\b`)
var str = `150 k
150 kilobyte
150 ka
150 k2
150 k)
150 k.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}