$re = '/(\d+\s*k)\b/';
$str = '150 k
150 kilobyte
150 ka
150 k2
150 k)
150 k.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);