#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(0)+$|^0+"
Local $sString = "005" & @CRLF & _
"0AB" & @CRLF & _
"000" & @CRLF & _
"0"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)