package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(0)+$|^0+`)
var str = `005
0AB
000
0`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}