using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d{1,3}(?:(?:(?=([\ _.,]?))(?:\1\d{3})*))$";
string input = @"1
12
123
123.456.789.884
12.55
12.345
2,234,647
2,234_754
2 234 723
123456
1
12
123
1234
12345
123456
1234567
123.456789";
RegexOptions options = RegexOptions.IgnorePatternWhitespace | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}