const regex = new RegExp('^\\d{1,3}(?:(?:(?=([\\ _.,]?))(?:\\1\\d{3})*))$', 'mg')
const str = `1
12
123
123.456.789.884
12.55
12.345
2,234,647
2,234_754
2 234 723
123456
1
12
123
1234
12345
123456
1234567
123.456789`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}