using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"item/(?!(action/edit)|(action/preview))([_0-9a-z-()@$!']+)";
string input = @"item/action/edit
item/action/preview
item/item-1
item/item-test";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}