const regex = new RegExp('item/(?!(action/edit)|(action/preview))([_0-9a-z-()@$!\\']+)', 'g')
const str = `item/action/edit
item/action/preview
item/item-1
item/item-test`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}