$re = '/(?<=^a{1,100})a/m';
$str = 'aaabbaa -> ---bbaa
aaxxaab -> --xxaab
xaaaaax -> xaaaaax';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);