re = /(?<=^a{1,100})a/m
str = 'aaabbaa -> ---bbaa
aaxxaab -> --xxaab
xaaaaax -> xaaaaax'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end