# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(?<!\d[,.])(?:(0)+\b|0+(?=[1-9]))/$1/gm;t' <<< "so ow - 00250 = 00000000 ]
12.055 12,005
0012.35 0000.35
0012,35 0000,35
"