use strict;
my $str = 'this/is/some/url
/this/is/some/url';
my $regex = qr/^\//mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";