package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d+)|([+-\/\*])`)
var str = `50+16-0*387/2+49`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}