$re = '/(\d+)|([+-\/\*])/';
$str = '50+16-0*387/2+49';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);