import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*?>(\\d\\d?)<";
final String string = "818y1873+130I have some text here09 124i10029102lsdgn2in3>31<\n"
+ "mkm1ikm12klni12m4j12??=?!=I\"=and then some text heremsiJR310>39<0MK)==!)=\"!";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}