import Foundation
let pattern = #"^.*?>(\d\d?)<"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
818y1873+130I have some text here09 124i10029102lsdgn2in3>31<
mkm1ikm12klni12m4j12??=?!=I"=and then some text heremsiJR310>39<0MK)==!)="!
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}